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Microfluidics Models : Microchannel Cell

Microchannel Cell
Introduction

This example was originally formulated by Albert Witarsa under Professor Bruce Finlayson’s supervision at the
University of Washington in Seattle. It was part of a graduate course in which the assignment consisted of using
mathematical modeling to evaluate the potential of patents in the field of microfluidics.

This model treats an H-microcell for separation through diffusion. The cell puts two different laminar streams in
contact for a controlled period of time. The contact surface is well defined, and by controlling the flow rate it is
possible to control the amount of species transported from one stream to the other through diffusion.

Figure 4-47: Diagram of the H-microcell.

Model Definition

The geometry of the microcell (Figure 4-43) is taken from Albert Witarsa’s and Professor Finlayson’s assignment.
The cell geometry is divided in half because of symmetry. The design aims to avoid upsets in the flow field when
the two streams, A and B, are united. This is to avoid the two streams mixing through convection, which would
mix all species equally and lead to loss of control over the separation abilities. The transport of species between
streams A and B should take place only by diffusion in order that species with low diffusion coefficients stay in
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their respective streams.

Figure 4-48: Model geometry. To avoid any type of convective mixing, the design must smoothly let both streams come in contact
with each other. Due to symmetry, it is sufficient to model half the geometry.

The simulations involve solving the fluid flow in the H-cell. According to the specifications, the flow rate at the
inlet is roughly 0.1 mm/s. This implies a low Reynolds number, well inside the region of laminar flow:

(4-12)

Equation 4-12 gives a Reynolds number of 0.001 for a water solution and the channel dimensions given in
Figure 4-43, a value typical for microchannels. Thus it is easy to get a numerical solution of the full momentum
balance and continuity equations for incompressible flow with a reasonable number of elements. The equations
that you need to solve are the Navier-Stokes equations at steady state:

(4-13)

Here ρ denotes density (kg/m3), u is the velocity (m/s), η denotes viscosity (Pa·s), and p equals pressure (Pa).

Separation in the H-cell involves species in relatively low concentrations compared to the solvent, in this case
water. This means that the solute molecules interact only with water molecules, and it is safe to use Fick’s law
to describe the diffusive transport in the cell. This mass-balance equation for a solute appears in the Convection
and Diffusion application mode and reads

(4-14) .

In this equation, D denotes the diffusion coefficient (m2/s) and c represents the concentration (mol/m3). In this

model, you use the parametric solver to solve Equation 4-14 for three different values of D—1·10-11 m2/s,

5·10-11 m2/s, and 1·10-10 m2/s— to simulate the mixing of different species.

You solve two versions of the model:

• In the first version, you assume that a change in solute concentration does not influence the fluid’s density
and viscosity. This implies that it is possible to first solve the Navier-Stokes equations and then solve the
mass balance equation.

• In the second version, you include a correction term in the viscosity that dependes quadratically on the
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concentration:

(4-15) .

Here α is a constant of dimension (concentration)-2. An influence of concentration on viscosity of this kind is
usually observed in solutions of larger molecules.

Next, consider the boundary conditions, starting with the Navier-Stokes equations. For the relevant boundary
groupings, refer to Figure 4-49.

Figure 4-49: Model domain boundaries.

At the inlets and outlets, Pressure conditions apply along with vanishing viscous stress:

(4-16)

Setting the pressure at the outlets to zero, the pressure at the inlets represents the pressure drop over the cell.
These inlet and outlet conditions comply with the H-cell being a part of a channel system of constant width,
which justifies the assumption of developed flow.

At the symmetry plane, choosing the boundary type Symmetry boundary sets the velocity component in the
normal direction of the surface to zero:

(4-17)

At the walls, No slip conditions state that the velocity is zero:

(4-18)

For the mass balances, the assumption that solute molecules interact only with water molecules implies that it is
sufficient to consider a single species A of concentration c. At the inlets, use the Concentration boundary
condition with the following values:
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(4-19)

Model the symmetry plane and cell walls with the Insulation/Symmetry condition:

(4-20)

This equation states that the flux of species perpendicular to the boundary equals zero. At the outlets, the
Convective flux condition applies, stating that the diffusive transport perpendicular to the boundary normal is
negligible:

(4-21)

This condition eliminates concentration gradients in the flow direction.

Results

Figure 4-44 shows the velocity field. The flow is symmetric and is not influenced by the concentration field.

Figure 4-50: Flow velocity field.

Figure 4-45 shows the concentration distribution for the lightest species in this study.
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Figure 4-51: Concentration distribution for a species with diffusivity 1·10-10m2/s.

Because of the relatively large diffusion coefficient, the degree of mixing is almost perfect for the lightest
species. The species with a diffusion coefficient ten times smaller than that of the lightest species shows a
different result.

Figure 4-52: Concentration distribution for a species with diffusivity 1·10-11m2/s.

The concentration distribution in Figure 4-52 indicates that the diffusion coefficient for the species is low enough
to avoid any significant mixing between streams A and B. The simulation clearly shows that the H-cell can
separate lighter molecules from heavier ones. A cascade of H-cells can achieve a very high degree of separation.

In some cases, especially those involving solutions of macromolecules, the macromolecule concentration has a
large influence on the liquid’s viscosity. In such situations, the Navier-Stokes and the convection-diffusion
become coupled, and they therefore must be solved simultaneously. Figure 4-53 shows the results of such a
simulation, which you repeat in the second version of this model. You can see that changes in the concentration
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influence the flow field. It is clear from this plot that the velocity becomes asymmetric due to changes in
viscosity. As a consequence of the modified flow field, the transport of molecules to the outlet B is also different
from the result using a constant flow field. You can see the difference by comparing Figure 4-54 with Figure 4-
52 on page 361.

Figure 4-53: Velocity field. The viscosity varies with the concentration according to η = η0(1+ α c2) with
α = 0.5 (m3/mol)2. The figure shows that the velocity field is affected by variations in concentration. Compare it to the velocity
field in Figure 4-44.

Figure 4-54: Concentration distribution for the species with diffusivity 1·10-11m2/s for the case where the fluid viscosity varies
with concentration. Comparison with the plot in Figure 4-52 shows that fewer molecules of the species are transported to outlet
B.

Model Library path: MEMS_Module/Microfluidics_Models/microchannel_h_cell

Modeling Using the Graphical User Interface
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1 Start COMSOL Multiphysics.

2 On the New page, set the Space dimension to 3D.

3 From the list of application modes, select MEMS Module>Microfluidics>
Flow with Species Transport>Incompressible Navier-Stokes.

4 Click the Multiphysics button, then click Add. As you can verify by inspection of the Multiphysics area on
the right, this adds an Incompressible Navier-Stokes and a Convection and Diffusion application mode to the
model. Later you will also see that a predefined coupling of the Navier-Stokes flow velocity has been included
for the Convection and Diffusion application mode.

5 Click OK.

OPTIONS AND SETTINGS

1 From the Options menu, select Constants.

2 Enter the following variable names, expressions, and (optionally) descriptions in the Constants dialog box;
when done, click OK.

NAME EXPRESSION DESCRIPTION
rho 1e3[kg/m^3] Density

eta 1e-3[Pa*s] Viscosity

D 1e-10[m^2/s] Diffusion constant

p0 2[Pa] Pressure drop

c0 1[mol/m^3] Inlet concentration

alpha 0.5[(m^3/mol)^2] Viscosity c^2-term prefactor

GEOMETRY MODELING

1 From the Draw menu, select Work-Plane Settings.

2 Use the default Quick work plane (the xy-plane at z = 0) by clicking OK.

3 From the Options menu, open the Axes/Grid settings.

4 On the Axis page, enter the following settings:

PROPERTY VALUE

x min -1

x max 15

y min -7

y max 7

5 On the Grid page, clear the Auto check box and set both the x spacing and the y spacing to 1. Click OK.

6 Click the Line button on the Draw toolbar, then click the points with the x- and y-coordinates at (0, 6) and
(0, 2).

7 Select the 2nd Degree Bezier Curve tool on the Draw toolbar and click at the coordinate pairs (0, 0) and
(2, 0).

Select the Line tool and click at the coordinates (12, 0).
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9 Select the 2nd Degree Bezier Curve tool and click at the coordinates (14, 0) and 
(14, 2).

10Select the Line tool and click at the coordinates (14, 6). Continue by clicking at the coordinates (13, 6) and
(13, 2).

11Select the 2nd Degree Bezier Curve tool and click at the coordinates (13, 1) and (12, 1).

12Select the Line tool and click at the coordinates (2, 1).

13Select the 2nd Degree Bezier Curve tool and click at the coordinates (1, 1) and (1, 2).

14Select the Line tool and click at the coordinates (1, 6).

15Click the right mouse button to close the set of lines and create a solid object, CO1.

You have now created half of the 2D cross section and can use copy, paste, and rotate operations to create the
other half.

1 Click first the Copy button and then the Paste button, both on the Main toolbar. Leave the Displacement
components at 0 and click OK to create the composite object CO2.

2 Click the Scale button on the Draw toolbar. Change the y component of the Scale factor to -1 (leave the
other parameters at their default values).

3 Click OK to flip CO2 over the x-axis.

4 From the Edit menu, choose Select All. (Alternatively, press Ctrl+A.)

5 Click the Create Composite Object button on the Draw toolbar.

6 Clear the Keep interior boundaries check box. Click OK.

The cross section is now finished and you can extrude it to the full 3D geometry.

7 Select Extrude from the Draw menu. Let the Distance remain equal to 1. Click OK.

The final geometry-modeling step is to scale the geometry to the correct scale.

8 Click the Scale button on the Draw toolbar.

9 Type 1e-5 in all three Scale factor edit fields. Click OK.

10Click the Zoom Extents button on the Main toolbar.

You do not need the 2D work plane any more, so you can remove it from the model:

1 From the Multiphysics menu, choose Model Navigator.

2 In the Multiphysics area to the right, select Geom2 (2D) and then click Remove.

3 Click OK to close the Model Navigator.

PHYSICS SETTINGS

Subdomain Settings
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1 From the Multiphysics menu, select 1 Incompressible Navier-Stokes (mmglf).

2 From the Physics menu, select Subdomain Settings.

3 Select Subdomain 1, then specify the settings in this table; when done, click OK.

PROPERTY VALUE

ρ rho

η eta

4 From the Multiphysics menu, select 2 Convection and Diffusion (chcd).

5 From the Physics menu, select Subdomain Settings.

6 Select Subdomain 1.

7 In the D (isotropic) edit field, type D. Note that the velocity variables from the Incompressible Navier-
Stokes application mode appear as predefined couplings.

8 Click OK to confirm the settings and close the dialog box.

Boundary Conditions
1 From the Multiphysics menu, select 1 Incompressible Navier-Stokes (mmglf).

2 From the Physics menu, select Boundary Settings.

3 Specify boundary conditions as in the following table; when done, click OK.

SETTINGS BOUNDARIES
2, 8

BOUNDARIES
20, 22

BOUNDARY 4 ALL
OTHERS

Boundary
type

Inlet Outlet Symmetry
boundary

Wall

Boundary
condition

Pressure,
no viscous
stress

Pressure,
no viscous
stress

 No
slip

p0 p0 0 - -

4 From the Multiphysics menu, select 2 Convection and Diffusion (chcd).

5 From the Physics menu, select Boundary Settings.

6 Specify the boundary conditions in the following table; when done, click OK.

SETTINGS BOUNDARY 2 BOUNDARY 8 BOUNDARIES
20, 22

ALL OTHERS

Type Concentration Concentration Convective
flux

Insulation/
Symmetry

c0 c0 0 - -

MESH GENERATION

1 From the Mesh menu, select Free Mesh Parameters.
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2 From the Predefined mesh sizes list, select Extra fine.

3 Click the Remesh button.

4 When the mesher has finished, click OK.

COMPUTING THE SOLUTION

Start by first computing the solution for the velocity field and then use that solution for solving the mass
transport problem.

1 Click the Solver Parameters button on the Main toolbar.

2 On the General page, select Direct (PARDISO) from the Linear system solver list.

3 Click OK.

4 Click the Solver Manager button on the Main toolbar.

5 On the Solve For page, select Incompressible Navier-Stokes (mmglf).

6 On the Initial Value page, click the Initial value expression option button in the Initial value area.

7 Click OK.

8 Click the Solve button on the Main toolbar.

You have now computed the velocity field and can use that solution to make a parametric analysis for the mass
transport problem with varying diffusivity.

1 Click the Solver Manager button on the Main toolbar.

2 On the Solve For page, select Convection and Diffusion (chcd).

3 Click the Initial Value tab, then click the Current solution option button in the Initial value area.

4 Click OK.

5 Click the Solver Parameters button on the Main toolbar.

6 From the Solver list, select Parametric.

7 In the Parameter name edit field, type D.

8 In the Parameter values edit field, type 1e-10 5e-11 1e-11.

9 Click OK.

10Click the Solve button on the Main toolbar.

POSTPROCESSING AND VISUALIZATION

To generate Figure 4-44 follow these steps:

1 From the Postprocessing menu, open the Plot Parameters dialog box.

2 On the General page, select the Slice and Arrow check boxes in the Plot type area.

3 Clear the Element refinement Auto check box and type 5 in the associated edit field.
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4 Click the Slice tab.

5 In the Predefined quantities list, select Incompressible Navier-Stokes (mmglf)>Velocity field.

6 From the Unit list, select mm/s.

7 In the Slice positioning area, set x levels to 5, y levels to 2, and z levels to 1.

8 Click the Arrow tab.

9 On the Subdomain Data page, verify that Velocity field is selected in the Predefined quantities list.

10In the Arrow positioning area, set the numbers of x points, y points, and z points to 14, 21, and 3,
respectively.

11In the Arrow parameters area, click the Color button. Select the black swatch from the palette in the
Arrow Color dialog box, then click OK.

12Select 3D arrow from the Arrow type list.

13Click Apply to generate the plot.

To generate Figure 4-45, continue with the following steps:

1 Clear the Arrow plot check box, then click the Slice tab.

2 From the Predefined quantities list, select Convection and Diffusion (chcd)>Concentration, c.

3 On the General page, select 1e-10 from the Parameter value list. Click OK.

Generate Figure 4-52 the same way as Figure 4-45, except use the parameter value 1e-11.

PHYSICS SETTINGS—STUDY 2

1 From the Multiphysics menu, select 1 Incompressible Navier-Stokes (mmglf).

2 From the Physics menu, select Subdomain Settings.

3 Change the viscosity expression to eta*(1+alpha*c^2). Click OK.

COMPUTING THE SOLUTION—STUDY 2

When the viscosity is concentration dependent you must solve all equations simultaneously.

1 Click the Solver Manager button on the Main toolbar.

2 On the Solve For page, select Geom1 (3D) from the Solve for variables list. Click OK.

3 Click the Solver Parameters button on the Main toolbar.

4 From the Solver list, select Stationary. Click OK.

5 Click the Solve button on the Main toolbar.

POSTPROCESSING AND VISUALIZATION—STUDY 2

Finally, generate Figure 4-53 and Figure 4-54 with the following steps:
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1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, select the Arrow check box in the Plot type area.

3 Click the Slice tab.

4 In the Predefined quantities list, select Incompressible Navier-Stokes (mmglf)>
Velocity field.

5 In the Unit list, select mm/s, then click Apply to generate Figure 4-53.

6 In the Predefined quantities list, select Convection and Diffusion (chcd)>Concentration, c.

7 On the General page, clear the Arrow check box in the Plot type area.

8 Click OK to close the dialog box and generate Figure 4-54.
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