
Pa c k ed Bed R e a c t o r

Introduction

The packed bed reactor is one of the most common reactors in the chemical industry, 
for use in heterogeneous catalytic processes. In essence, the reactor consists of a 
container filled with catalyst particles. These particles can be contained within a 
supporting structure, like tubes or channels, or they can be packed in one single 
compartment in the reactor.

The structure that is formatted by the packed catalyst particles makes the modeling of 
mass and energy transport in the reactor a challenging task. The difficulty lies in the 
description of the porous structure, which gives transport of different orders of 
magnitudes within the particles and between the particles. In most cases, the structure 
in between particles is described as macroporous and the particle radius can be of the 
order of magnitude of 1 mm. When a pressure difference is applied across the bed, 
convection arise in the macropores. The pores inside the catalyst particles form the 
microstructure of the bed. The pore radius in the particles is often between one and 
ten micrometer.

This model presents a simple and fast alternative for studying microscale and 
macroscale mass balances in packed beds and other heterogeneous reactors with 
bimodal pore distribution. Using a multigeometry approach, the model provides the 
mass and reaction distributions along the reactor and within each catalyst pellet along 
the reactor length. This makes it possible to evaluate the utilization of catalyst load, 
optimal pellet size, or inlet temperature.

In this example, volatile organic compounds (VOC) and CO are oxidized in a catalytic 
converter. Propylene is used as representative for hydrocarbons present in the feed 
stream, which could be, for example, exhaust gas from a combustion process.

Model Definition

The following chemical reactions describe the catalytic conversion carbon monoxide 
and by-product hydrocarbon:

 (8-143)CO 1
2
---O2+ CO2→
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 (8-144)

For these heterogeneous catalytic reactions the rates (mol/(m3·s)) are given by

 (8-145)

 (8-146)

The rate and adsorption constants are given by Arrhenius expressions:

 (8-147)

The values of the frequency factors and activation energies (J/mol) are taken from the 
literature (Ref 2) and presented in Table 8-3.

The chemical reactions given in Equation 8-143 and Equation 8-144 describe a 
process that is limited by the second-order rate expression at high temperatures when 
the surface coverage is low. At low temperatures the adsorbtion reactions will be slower 
and limit the reaction rate due to a shortage of free catalytic sites.

The pressure drop in the reactor is described by the Ergun equation

 (8-148)

where P is the pressure (kPa), Φ the porosity, Dp the particle diameter (m), µ denotes 
the gas viscosity (kg/(m·s)), ρ the gas density (kg/m3), and x the reactor length (m). 
u is the reactor flow velocity (m/s) that depends on the pressure drop according to

TABLE 8-3:  ARRHENIUS PARAMETERS

RATE/ADSORPTION 
CONSTANT

FREQUENCY FACTOR 
(JOULE/MOL)

ACTIVATION ENERGY 
(JOULE/MOL)

k1 7.07·1013 1.09·105

k2 1.47·1015 1.26·105

KCO 8.1 -3400

KC3H6 257.9 1588
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 (8-149)

where ufeed is the inlet velocity and C the total concentration (mol/m3).

The mass transport in the reactor is given by the convection and diffusion equation

 (8-150)

where D is the diffusion coefficient (m2/s) and R is a source term (mol/(m3·s)). 
Equation 8-150 needs to be solved for all species participating in Equation 8-143 and 
Equation 8-144. Each equation also needs proper boundary conditions.

At the inlet the reactant concentration is known:

 (8-151)

 (8-152)

 (8-153)

 (8-154)

 (8-155)

At the outlet, the convective flux condition will let the product and reactants leave with 
the flow.

 (8-156)

At first glance, these equations appear straight forward, especially if the velocity vector 
is given by an analytical expression, which is the case for plug flow in a packed bed 
reactor. However, the source term, R, depends on the transport inside the catalyst 
particles. The molar flux at the outer surface of the particles multiplied by the available 
outer surface area of the particles per unit volume gives the proper source term:

 (8-157)

In this equation, N denotes the flux inside the porous particle (mol/(m2·s)) and n is 
the outward unit vector normal to the particle surface. Equation 8-157 is only valid at 
the particle surface, where the independent radius variable r (introduced below) equals 
the particle radius, rp. Furthermore, Ap, denotes the pellet surface to volume ratio 
(m2/m3). This property is related to the pellet radius as

u ufeed
C

Cfeed
-------------

Pfeed
P

-------------⋅ ⋅=

∇ D∇c–( )⋅ R u ∇c⋅–=

cCO cCOin=

cC3H6 cC3H6in=

cO2 cO2in=

cCO2 0=

cH2O 0=

n D∇– c( )⋅ 0=

R Ap N n⋅( )= at  r rp=
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 (8-158)

To properly calculate R, a mass balance is required for the catalyst pellet interior. Such 
a mass balance can be expressed as

 (8-159)

Here, Dpc is the effective diffusion coefficient in the particle, cp is the concentration in 
the particle, and Rp is the reaction rate for the heterogeneous reaction in the particle. 
In the catalyst pores, transport takes palace by diffusion only.

Equation 8-159 gives mass balance for each species for the catalyst pellet. Because the 
pellets are spherical, it is convenient to express these mass balances in spherical 
coordinates. Equation 8-159 then becomes

 (8-160)

where r (m) is the independent variable for the position along the radius of the particle. 
The equation is scaled with the particle radius to get a geometry with a lower aspect 
ratio. This gives the final formulation:

 (8-161)

The diffusion-reaction equation, combined with the boundary conditions for the 
particle, give the concentration distribution in the particle. The boundary conditions 
are:

 (8-162)

 (8-163)

where ε denotes the porosity of the particle, and c and cp represent the species 
concentrations. This implies symmetry at the center of the particle. In addition, the 
concentration at the surface of the particle is equal to the concentration outside the 
particle compensated to account for the part of the particle volume that is occupied by 
solid catalyst support.
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The concentration distribution in the particle gives the molar flux at every point in the 
particles. This implies that the source term for the catalyst bed is given by the solution 
of the microscale mass balance:

 (8-164)

A complication in solving the derived system of equations is that the macroscale and 
microscale balances are defined in different coordinate systems. This problem is 
general for many chemical reaction engineering applications and is often solved by 
using an analytical approximation of the solution to the microscale balance. However, 
such an approach cannot be used for complicated reaction mechanisms involving 
several reaction species. The solution exemplified here is general and can be used for 
very complex reaction mechanisms involving a large number of species.

Results and Discussion

Figure 8-72 shows the concentration of reacting species in the reactor as function of 
position. The levels of carbon monoxide and propylene are significantly reduced.

Figure 8-72: The concentration of reactants and products along the reactor length. The 
pellet radius rp is 2.5mm.

R Ap Dpc∇cp– n⋅( )=
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The concentration can also be evaluated within each pellet, revealing whether or not 
the catalyst comes to efficient use. Figure 8-73 shows an example of this.

Figure 8-73: The concentration of in-pellet CO as function of reactor position. The scaled 
pellet radius is given on the r-axis and the reactor position along the x-axis.

From Figure 8-73 it is clear that the CO concentration is low at the center of the pellet 
at all reactor positions. This means that reactor performance is limited by diffusion 
within the pellets and that active catalyst material in the center of the pellet will never 

x
r
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come to use. Reducing the pellet diameter could potentially remedy this situation, and 
simulation results shown in Figure 8-74 confirm this notion.

Figure 8-74: The concentration of in-pellet C3H6 at three different reactor positions (5, 
15, and 25 cm). Solid lines represents a pellet radius of 2.5 mm and lines with triangular 
markers represents a pellet radius of 1.8 mm.

With a pellet radius of 2.5 mm, the reactor is limited by the in-pellet diffusion, as is 
indicated by the slope of the solid lines. The effect of this is that the active sites in the 
interior of the pellets are not used to their full potential. If the pellet size is reduced 
(represented by the lines with a triangular marker), the lines level out faster, suggesting 
larger reaction limited regions. The effect on C3H6 conversion in the simulated case is 
an improvement from 94% to 97%.
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Model Library path: Chemical_Engineering_Module/
Transport_and_Reactions/packed_bed_reactor

Modeling Using the Graphical User Interface

The approach in this example is to treat the bed as a 1D model with independent 
variable x. At each x-coordinate, there is a model of a single pellet representative of all 
pellets at that position in the packed bed. Because the pellets are spherical and the 
surface concentrations can be considered constant around a particle, a 1D model with 
independent variable r is used for each particle. To model pellets along the packed bed, 
many such 1D models can be placed side by side, effectively creating a 2D geometry 
with independent variables x and r.

In the resulting model, all pellets can be modeled independently. There is therefore a 
2D geometry for the pellets and a 1D geometry for the packed bed. The model 
involves a two-way coupling: the packed bed concentration enters the boundary 
condition for the particles, and the source term in the packed bed involves the flux at 
the particle surfaces.

M O D E L  N A V I G A T O R

1 Start COMSOL Multiphysics.

2 In the Model Navigator, click the Multiphysics button and select 2D in the Space 

dimension list.

3 Click the Add Geometry button and enter Particles in the Geometry name edit 
field.

4 Change the independent variables to x r z, then click OK to close the dialog box.

5 Select the application mode COMSOL Multiphysics>Chemical Engineering Module>Mass 

Transport>Diffusion. Enter C3H6p COp CO2p H2Op O2p in the Dependent variables 

edit field. Click the Add button.

6 Click the Add Geometry button and type Reactor in the Geometry name edit field. 
Also set the Space dimension to 1D. Close the dialog box by clicking OK.

7 Highlight the application mode COMSOL Multiphysics>Chemical Engineering 

Module>Mass Transport>Convection and Diffusion. Enter C3H6 CO CO2 H2O O2 in the 
Dependent variables edit field.

8 Click the Add button.
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9 Select the application mode COMSOL Multiphysics>PDE Modes>PDE, Coefficient Form. 
In the Dependent variables edit field, type P.

10 Click OK to close the Model Navigator.

G E O M E T R Y  M O D E L I N G

1 From the Multiphysics menu, choose Reactor: Convection and Diffusion (chcd).

2 Hold the Shift key and click the Line button on the Draw toolbar to open the Line 
dialog box.

3 In the x edit field, type 0 0.3, then click OK to close the dialog box.

4 Click the Zoom Extents button on the Main toolbar.

O P T I O N S  A N D  S E T T I N G S

1 From the Options menu, choose Constants.

2 Click the Import Variables From File button in the lower left of the Constants dialog 
box.
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3 Select the file packed_bed_reactor_const.txt (located in the same Model 
Library folder as the MPH-file). Alternatively, enter the following parameter names 
and values in the Constants dialog box:

NAME EXPRESSION DESCRIPTION

P_feed 2[atm] Feed Pressure

T 508[K] Reactor Temperature

R 8.314[Pa*m^3/mol/K] Gas constant

kmCO 3.90[cm/s] External mass transfer 
coefficient for CO

kmO2 4.07[cm/s] External mass transfer 
coefficient for O2

kmC3H6 3.90[cm/s] External mass transfer 
coefficient for CO

D_CO 0.0487[cm^2/s] Diffusion coefficient for CO

D_O2 0.0469[cm^2/s] Diffusion coefficient for O2

D_C3H6 0.0487[cm^2/s] Diffusion coefficient for C3H6

D_prod 0.0487[cm^2/s]

E1 13108[K] Activation energy for R1

E2 15109[K] Activation energy for R2

A1 7.07e19[cm^3/mol/s] Pre exponential factor for 
reaction 1

A2 1.47e21[cm^3/mol/s] Pre exponential factor for 
reaction 2

Aco 8.099e6[cm^3/mol] Eq constant for adsorption term

Ac3h6 2.579e8[cm^3/mol] Eq constant for adsorption term

Eco -409[K] Activation energy for adsoption 
term

Ec3h6 191[K] Activation energy for adsoption 
term

u_feed 75[cm/s] Linear inflow velocity

dHr1 -67.63e3[cal/mol] Heat of Reaction for R1

dHr2 -460.4e3[cal/mol] Heat of Reaction for R2

Cp 0.25[cal/g/K] Effective Heat capacity for bed

kp 0.779[W/(m*K)] Thermal conductivity (ripped 
from other model)

por_b 1-rho_b/rho_p Porosity of the bed (void/total)

rho_b 0.51[g/cm^3] Density of bed
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4 Choose Options>Expressions>Global Expressions.

5 Click the Import Variables From File button in the lower left of the Global Expressions 
dialog box and select the file packed_bed_reactor_expr.txt (located in the same 
Model Library folder as the MPH-file). Alternatively, enter the following parameter 
names and values in the Global Expressions dialog box:

rho_p 0.68[g/cm^3] Density of pellet

Rr 5[cm] reactor radius

Ra pi*Rr^2 Reactor area

eta 0.028e-2[g/cm/s] Fluid viscosity

rho_feed 1.292[kg/m^3] Inlet gas density

Ctot_feed P_feed/R/T Total feed concentration

x_CO_feed 0.005 Molar fraction of CO in feed

x_O2_feed 0.0075 Molar fraction of O2 in feed

x_C3H6_feed 0.000125 Molar fraction of C3H6 in feed

Cinert_feed (1-x_CO_feed-x_O2_f
eed-x_C3H6_feed)*Ct
ot_feed

Concentration of inert in feed

Ap 3/rp Surface area of particles per 
unit volume

rp 0.25[cm] particle radius

NAME EXPRESSION DESCRIPTION

Ctot (Cinert_feed+CO+O2+
CO2+C3H6+H2O)

Total concentration

k1 A1*exp(-E1/T) Rate constant for reaction 1

k2 A2*exp(-E2/T) Rate constant for reaction 2

KCO Aco*exp(-Eco/T) Adsorbtion constant for CO

KC3H6 Ac3h6*exp(-Ec3h6/T) Adsorbtion constant for C3H6

R1 k1*COp*O2p/
(1+KCO*COp+KC3H6*C3
H6p)^2

Rate expression for reaction 1

R2 k2*C3H6p*O2p/
(1+KCO*COp+KC3H6*C3
H6p)^2

Rate expression for reaction 2

u u_feed*(Ctot/
Ctot_feed)*(P_feed/
P)

Linear velocity

NAME EXPRESSION DESCRIPTION
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6 Click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings—Convection and Diffusion
1 From the Multiphysics menu, select 2 Reactor: Convection and Diffusion (chcd).

2 From the Physics menu, select Subdomain Settings. 

3 Select Subdomain 1 in the Subdomain Settings dialog box.

4 Specify the settings as in the following table.

5 Click the Init tab and type 1e-6 in all edit fields.

6 Click OK.

Boundary Conditions—Convection and Diffusion
1 From the Physics menu, choose Boundary Settings.

2 Select Boundary 1.

3 Enter the species concentrations of the inlet stream. For each species in the table, 
find the Boundary condition list and select Concentration. Type in the entries from the 
following table:

4 Select Boundary 2.

beta G*(1-por_b)/
(rho_feed*2*rp*por_
b^3)*(150*(1-por_b)
*eta/(2*rp)+1.75*G)

Ergun equation constant

G u_feed*rho_feed superficial mass velocity

F0 Ctot_feed*u_feed*Ra Inlet molar flow

F Ctot*u*Ra Molar flow [mol/s]

SETTINGS C3H6 CO CO2 H2O O2

D D_C3H6 D_CO D_prod D_prod D_O2

R -Ap*C3H6fl
ux

-Ap*COflux -Ap*CO2flu
x

-Ap*H2Oflu
x

-Ap*O2f
lux

u u u u u u

BOUNDARY C3H6 CO CO2 H2O O2

1 x_C3H6_feed*
Ctot_feed

x_C3H6_feed
*Ctot_feed

0 0 x_C3H6_feed
*Ctot_feed

NAME EXPRESSION DESCRIPTION
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5 Set the Boundary condition to Convective flux for all species on the outlet boundary.

6 Click OK.

Subdomain Settings—PDE, Coefficient Form
1 From the Multiphysics menu, select 3 Reactor: Coefficient Form (c).

2 From the Physics menu, select Subdomain Settings. 

3 Select Subdomain 1 in the Subdomain Settings dialog box.

4 Specify the settings as in the following table.

5 Click the Init tab and type 1e5 in all edit fields.

6 Click OK.

Boundary Conditions—PDE, General Form
1 From the Physics menu, choose Boundary Settings.

2 Select Boundary 1, then type 1 in the h edit field.

3 In the R edit field, type P_feed.

4 Select Boundary 2, then click the Neumann boundary condition button.

5 Click OK.

The source terms in the reactor mass balances depend on fluxes from the catalyst 
pellets. To know this the catalyst model must also be set up. Once this is done the 
reaction rate can be calculated by coupling the two models.

G E O M E T R Y  M O D E L I N G

1 From the Multiphysics menu, choose 1 Particles: Diffusion (chdi).

2 Draw a unit square with its lower left corner at (0,0).

3 Click the Zoom Extents button on the Main toolbar.

P H Y S I C S  S E T T I N G S

Subdomain Settings—Convection and Diffusion
1 From the Physics menu, select Subdomain Settings.

2 Select Subdomain 1 in the Subdomain Settings dialog box.

SETTINGS VALUE

f Px+beta*(F/F0)*(P_feed/P)
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3 Specify the settings according to the following table.

4 On the Init page, type 1e-6 in all edit fields.

5 Click OK.

Boundary Conditions—Diffusion
1 From the Physics menu, choose Boundary Settings.

2 Select Boundary 3.

3 Enter the species concentration on the pellet surface. This can be taken from the 
reactor model through a coupling variable. For now, find the Boundary condition list 
and select Concentration, then type the entries from the following table:

4 Leave Boundaries 1, 2, and 4 with the default boundary condition Insulation/

Symmetry.

5 Click OK.

The species concentration at the pellet boundary can be taken from the reactor model. 
Each position along the x-axis, in the reactor model, corresponds to a position along 
the x-axis in the pellet model. So the concentration at pellet-bulk interface can be taken 
form the reaction model with a Subdomain Extrusion coupling variable. This 
concentration at the pellet surface will give rise to mass flux at the interface. This mass 
flux can be coupled back to give the total reactor reaction rate for all species. To set up 
the coupling follow these steps:

1 From the Multiphysics menu, select 2 Reactor: Convection and Diffusion (chcd).

2 Select Options>Extrusion Coupling Variables>Subdomain Variables.

SETTINGS C3H6P COP CO2P H2OP O2P

D (anisotropic) 0 0 0 
(D_C3H6/
rp^2)*r^2

0 0 0 
(D_CO/
rp^2)*r^2

0 0 0 
(D_prod/
rp^2)*r^2

0 0 0 
(D_prod/
rp^2)*r^2

0 0 0 
(D_O2/
rp^2)*r
^2

R -r^2*R2 -r^2*R1 r^2*(R1+3*
R2)

r^2*3*R2 -r^2*(0
.5*R1+4
.5*R2)

BOUNDARY C3H6P COP CO2P H2OP O2P

3 C3H6bulk CObulk CO2bulk H2Obulk O2bulk
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3 Define the coupling variables by entering names and expressions according to the 
following table:

4 For each entry also select General transformation. This must be done for all 5 species.

5 Click the Destination tab.

6 In the Geometry list, choose Particles. Make sure that the Level list is set to Boundary.

7 Select CObulk in the Variable list.

8 Select Boundary 3

9 Enter x*0.30 in the Destination transformation edit field. This correspond to that 
the reactor length is only 30% of the pellet domain because the pellet domain is 
scaled.

10 Repeat Steps 8 and 9 for all other species in the Variable list.

11 Click OK.

To uphold the concentration constraint on the particle surface there will be a diffusive 
flux out through the top boundary of the pellet. This flux is equal to the total reaction 
rate if it is multiplied by the specific surface area, at steady state. But to make this flux 
available this must be coupled back to the reactor geometry.

1 From the Multiphysics menu, select 1 Particles: Diffusion (chdi).

2 Select Options>Extrusion Coupling Variables>Boundary Variables.

3 Mark Boundary 3 in the Boundary Selection list.

4 Define the coupling variables by entering names and expressions according to the 
following table:

NAME EXPRESSION

CObulk CO

O2bulk O2

CO2bulk CO2

C3H6bulk C3H6

H2Obulk H2O

NAME EXPRESSION

COflux D_CO*COpr*r/rp

O2flux D_O2*O2pr*r/rp

CO2flux D_prod*CO2pr*r/rp
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5 For each entry also click the General transformation button. This must be done for 
all 5 species.

6 Click the Destination tab.

7 In the Geometry list, choose Reactor and make sure that the Level list is set to 
Subdomain.

8 Select COflux in the Variable list.

9 Select Subdomain 1. In the Destination transformation edit field, type x/0.30. This 
transformation accounts for the fact that the reactor length is only 30% of the pellet 
domain because the pellet domain is scaled.

10 Repeat Steps 8 and 9 for all other species in the Variable list.

11 Click OK.

M E S H  G E N E R A T I O N

1 From the Multiphysics menu, select 2 Reactor: Convection and Diffusion (chcd).

2 From the Mesh menu, choose Free Mesh Parameters.

3 In the Maximum Element Size edit field, enter 0.0025.

4 Click the Remesh button and close the dialog box.

5 From the Multiphysics menu, select 1 Particles: Diffusion (chdi).

6 From the Mesh menu, choose Mapped Mesh Parameters.

7 Click the Boundary tab. Select Boundaries  1 and 4 by Ctrl-clicking their entries in 
the Boundary selection list.

8 Select the Constrain element distribution check box, then enter 30 in the Number of 

edge elements edit field. Also enter 0.2 in the Element ratio edit field. This makes 
the mesh finer near the pellet surface.

9 Select Boundary 3 in the Boundary selection list. Select the Constrain element 

distribution check box, then enter 120 in the Number of edge elements edit field.

10 Click Remesh. When the mesher has finished, click OK to close the dialog box.

Now there are equally many numbers of elements on the coupled lines, which is good 
for stability reasons when coupling in both directions.

C3H6flux D_C3H6*C3H6pr*r/rp

H2Oflux D_prod*H2Opr*r/rp

NAME EXPRESSION
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O P T I O N S  A N D  S E T T I N G S

To evaluate the conversion of C3H6 and CO it is convenient to set up dedicated 
expressions for this.

1 From the Multiphysics menu, select 2 Reactor: Convection and Diffusion (chcd).

2 From the Options menu, choose Integration Coupling Variables>Boundary Variables.

3 Select 2 in the Boundary Selection list.

4 Create the following variables:

5 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

To save memory the Stationary Segregated Solver will be used. This solver alternates 
between solving for the species in the Reactor geometry and the pellet each iteration. 
To avoid feedback from the variables that are currently not being solved for a strict one 
way coupling will be enforced for the couplings between the geometries. This is not 
default when the coupling takes place on a boundary condition, which is the case for 
the Particles geometry.

1 From the Multiphysics menu, select 1 Particles: Diffusion (chdi).

2 Go to Properties in the Physics menu.

3 Set the Constraint type drop down list to Non-Ideal. Click OK to close the dialog box.

4 Click the Solver Parameters button on the toolbar.

5 Select the Stationary Segregated solver in the Solver list. Click OK to close.

6 Click the Solve button.

The remaining solving stages continue after the postprocessing section.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To create Figure 8-72 perform the following steps

1 From the Postprocessing menu, open the Domain Plot Parameters dialog box.

2 On the General page, select the Keep current plot check box.

3 Click the Title/Axis button.

4 In the Title edit field, enter Concentration along reactor length.

NAME EXPRESSION

X_C3H6 1-C3H6/(x_C3H6_feed*Ctot_feed)

X_CO 1-CO/(x_CO_feed*Ctot_feed)
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5 Enter Reactor length, [m] in the First axis label and Concentration, [mol/
m<sup>3</sup>] in the Second axis label edit field.

6 Click the Line/Extrusion tab.

7 Select Concentration, C3H6 in the Predefined quantities list.

8 Click the Line Settings button. Select Color in the Line color list.

9 Click the Color button and select black. Click OK twice to close the dialog boxes.

10 Click Apply to plot the concentration.

11 Repeat Steps 7 to 10 for the species CO, CO2, and O2 giving each line a different 
color.

12 Click OK.

To create Figure 8-73 preform the following steps

1 From the Postprocessing menu open the Plot Parameters dialog box.

2 Click the Surface tab.

3 Select Concentration, O2p in the Predefined quantities list.

4 Click the Height Data tab.

5 Select the Height data check box.

6 From the Predefined quantities list, select Concentration, O2p. Click OK.

To investigate if better pellet utilization can be achieved, the pellet size is reduced. This 
affects the packing of the catalyst and reduces the diffusive length within the pellets.

C O M P U T I N G  T H E  S O L U T I O N

1 Click the Solver Parameters button on the Main toolbar.

2 From the Solver list, select Parametric segregated.

3 To vary the pellet radius, type rp in the Parameter names edit field.

4 In the Parameter values edit field, type 0.0025 0.0018.

5 On the Parametric page, select the Manual tuning of parameter step size check box.
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6 Enter the values in the following table:

This ensures that the solver does not jump from 0.0025 to 0.0018 in a single step; 
taking small steps can increase the solver stability.

7 Click OK to close the Solver Parameters dialog box.

8 Click the Restart button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To reproduce the plot in Figure 8-74, perform the following steps:

1 From the Postprocessing menu, open the Cross-Section Plot Parameters dialog box.

2 On the General page, select 0.0025 in the Solutions to use list.

3 Select the Keep current plot check box.

4 On the Line/Extrusion page, select Concentration, C3H6 from the Predefined quantities 

list.

5 In the Cross-section line data area, set x1 to 0 and r1 to 1.

6 Select the Multiple parallel lines check box.

7 Set the Number of lines to 3, then click Apply.

8 On the General page, select 0.0018 in the Solutions to use list.

9 Click OK.

SETTINGS C3H6

Initial Step size 0.0002

Minimum Step size 1e-6

Maximum step size 0.0003
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