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Th e rmoe l a s t i c  Damp i n g  i n  a  MEMS 
Re s ona t o r

Introduction

A high Q value is a key factor of a MEMS resonator. It it essential that the resonator 
vibrates consistently at the desired frequency and that it requires as little energy as 
possible to maintain its vibration. These features can be characterized by the 
resonator’s Q value, which is a measure of the sharpness of its spectrum’s peak. There 
are several ways to define the Q value, for example:

 (1)

where W0 is the total stored vibrational energy, ΔW is the energy lost per cycle, ω0 is 
the natural angular frequency, δ is the damping factor (vibration decays exponentially 
with δt), and Δω is the half power width of the spectrum.

In order to improve the resonator, the designer needs to consider all aspect that 
produce damping and noise to the system. For example, resonators are usually run in 
vacuum to minimize effects of air and squeeze-film damping.

Thermoelastic damping (Ref. 1, Ref. 2, and Ref. 3) is an important factor that the 
resonator designer needs to address. It is a result of a phenomenon called thermoelastic 
friction, which takes place when you subject any material to cyclic stress. The stress 
results in deformation, and the required energy is mostly stored as internal potential 
energy. However, materials heat under compressive stress and cool under tensile stress. 
Thus, due to the heat flow from warmer to cooler regions energy is also lost as 
nonrecoverable thermal energy. The amount of thermoelastic friction and damping 
depends on the rate of this energy loss. The magnitude of the energy loss depends on 
the vibrational frequency and on the structure’s thermal relaxation time constant, 
which is the effective time the material requires to relax after an applied constant stress 
or strain. Therefore, the effect of thermoelastic dissipation, and consequently the 
damping, is most pronounced when the vibration frequency is close to the thermal 
relaxation frequency.
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For simple structures, researchers have developed analytical expressions to estimate 
thermoelastic damping. According to Zener (Ref. 1 and Ref. 2), you can calculate the 
Q value for a resonator with a single thermal mode by: 

 (2)

where E is the Young’s modulus, α is the thermal expansion coefficient, T0 is the 
resonator temperature at rest, ρ is the density, Cp is the heat capacity of the material, 
ω is the vibration angular frequency, and τ is the thermal relaxation time of the system. 
Thus it is easy to see that in order to have good Q value, the system needs to be 
designed so that ω is as far from 1/τ as possible.

The natural frequency of a beam clamped at both ends can be calculated as (Ref. 4) 

 (3)

where a0 equals 4.730; h and L are the thickness and length of the beam, respectively; 
and E and ρ are material parameters as above.

The thermal relaxation time of the beam is given by

 (4)

where κ is the thermal conductivity and other parameters are as above.

The problem is that Equations 2 through 4 are valid only for very simple structures. 
Therefore more advanced methods, such as FEA, are preferable.

This example shows how to model thermoelastic damping with COMSOL 
Multiphysics. To be able to compare with measurements and analytical expressions, 
this example illustrates a simple beam resonator in 2D and 3D. The Q value and 
natural frequency is solved with an eigenfrequency analysis that combines heat transfer 
and structural mechanics in one equation system. Thus the eigenmodes are 
thermoelastic.

This example was inspired by the work of Amy Duwel and others (Ref. 1).
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Model Definition

Figure 1 shows the geometry. The resonator is a beam of silicon with length 400 μm, 
height 12 μm, and width 20 μm. The beam is fixed at both ends, and it vibrates in a 
flexural mode in the z direction (that is, along the smallest dimension). The model 
assume that the vibration takes place in vacuum. Thus there is no transfer of heat from 
the free boundaries. The model also assumes that the contact boundaries are thermally 
insulated.

Figure 1: Geometry of the modeled beam. The beam is fixed at both ends.

Table 1 lists the physical properties of the beam material and the surroundings: 

TABLE 1:  MATERIAL PROPERTIES (POLYSILICON)

PROPERTY VALUE

Young’s modulus, E 157 GPa

Density, ρ 2330 kg/m3

Poisson’s ratio, ν 0.3

Thermal expansion coefficient, α 2.6·10-6 K-1

Specific heat, Cp 700 J/(kg·K)

Thermal conductivity, k 90 W/(m·K)

Ambient and initial beam temperature, Tinit 300 K
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To gain information about the quality of the resonator, it is of interest to know its 
natural frequency and Q value. To do this, you run an eigenfrequency analysis to find 
the eigenvalues for this system. For a system with damping, the eigenvalue λ contains 
information about the natural frequency and Q value according to: 

 (5)

The eigenvalues appear as complex conjugates, and ω0 and Q are therefore given as 
absolute values.

At this point, to avoid any confusion it is good to note that here Q refers to the 
resonator’s quality, whereas later in this text Qheat refers to the heat source term in the 
heat equation.

To model thermoelastic damping, you must consider both the thermal problem and 
the structural problem. Furthermore, there is a 2-way coupling between them: the 
strain rate heats or cools the material locally, which produces thermal strains.

The relation between the material stress σ and strain ε is given by 

 (6)

where εel and εth are the elastic and thermal strains, respectively, D is the 6 × 6 elasticity 
matrix, and all stresses and strains are denoted with 6-component vectors consisting of 
x, y, and z normal components followed by the xy, yx, and xz shear components.

It is possible to expand this for an isotropic material:

 (7)
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where T is the strain temperature, Tref is the stress-free reference temperature, and α 
is the thermal expansion coefficient.

The heat balance equation is

 (8)

where k is the thermal conductivity. For a linear thermoelastic solid, the entropy per 
unit volume is:

 (9)

where T0 is the reference temperature, the volumetric heat capacity ρCP is assumed 
independent of the temperature, and

 (10)

where σ is the stress vector, and αvec is the thermal expansion vector. For an isotropic 
material, Equation 10 simplifies into

 (11)

For small deformations and small variation of the temperature, Equation 8 is linearized 
as:

 (12)

Finally, the frequency decomposition for the temperature is performed

 (13)

where jω = −λ is the complex angular frequency. Equation 12 gives

 (14)

where the heat source term is

 (15)

You model the problem with the damped eigenfrequency analysis for the beam, which 
is coupled with the thermal problem Equation 14.
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In the eigenfrequency analysis, you use the temperature computer from Equation 14 
as the strain temperature and set the strain reference temperature to zero, Tref = 0. This 
is because the solution physically corresponds to thermoelastic oscillations of small 
amplitude—it is initialized to zero. However, T0 in Equation 12 and Equation 15 is 
the actual temperature of the beam at rest.

Results and Discussion

Figure 2 and Figure 3 show the eigenmodes and temperature distribution 
corresponding to the found eigenvalue. Solved natural frequencies and Q values are 
given in Table 2. Reference data, one calculated with Equation 2 to Equation 4 and 
the others from measurements (see Ref. 1), are also given.

The Q value given by the 3D model appear to be roughly 10% smaller than the other 
estimates. One reason for this difference comes from the simplifying assumption that 
concerns both the Zener’s equation (Equation 2) and the plane stress method. For 
example, the plane stress method assumes that the structure is very thin and that there 
are no stresses perpendicular to the plane. However, looking at the 3D model in more 
detail, you find that stresses and their spatial derivatives have components of equal 
magnitude in all three dimensions. The model also assumes that the beam was perfectly 
fixed at its ends. Physically, this cannot happen, and allowing more loose contact 
lowers the natural frequency and improves the Q value.

One factor that also affects the simulated Q values is the boundary condition for the 
thermal equation. This example uses thermal insulation on all boundaries, but you can 
assume that there is a flux of heat at least from both ends of the beam. If you simply 
assign a constant temperature (T = 0) to the beam ends, the Q value improves 
considerably. The physically correct result should be somewhere between these two 
estimates.

A look at Figure 2 and Figure 3 shows a temperature distribution that appears to agree 
with the theory: the temperature is higher near the compressive strain and lower near 
the tensile strain. 

TABLE 2:  COMPARISON OF NATURAL FREQUENCY AND Q VALUE.

SOURCE F0 (MHZ) Q

3D model 0.63 MHz 9151

2D model 0.63 MHz 10,170

Equation 0.63 MHz 10,260

Measurements (Ref. 1) 0.57 MHz 10,281
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Note, however, that you should not take the displayed temperature range (−4 K to 
4 K) literally because the software normalizes the solution from the eigenfrequency 
solver.

Figure 2: First eigenmode and temperature distribution of the 3D model.
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Figure 3: First eigenmode and temperature distribution of the 2D model.

Modeling in COMSOL Multiphysics

To create a model of thermoelastic damping with COMSOL Multiphysics requires two 
application modes. For the 3D model, use the Solid, Stress-Strain application mode 
from the MEMS Module and the steady-state Conduction application mode from the 
base package. In 2D, use the Plane Stress application mode from the MEMS Module 
with the same Conduction application mode as in 3D.

In this example you guide the eigenfrequency solver to find the eigenfrequency near 
the expected natural frequency (Equation 3). Alternatively, you can first solve the 
undamped eigenfrequency f0 (select Eigenfrequency analysis in the Solver Parameters 
dialog box and solve only for the structural application mode). This approach is also 
valid for more complex geometries where you do not have an analytical expression for 
the estimated natural frequency.

This model, which consists of 2nd-order (structural) and 1st-order (thermal) 
eigenvalue problems, is numerically quite challenging. You can improve the results’ 
accuracy by manually scaling the dependent variables. This is an approach that you can 
use more generally. Once you know the magnitudes of the dependent variables, go to 
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the Advanced page in the Solver Parameters dialog box and define manual scaling of the 
dependent variables.

For the 3D problem you can utilize its symmetry. The beam is truncated to 10 um in 
the width direction. Thus you get a smaller mesh size, but it also makes the problem 
easier to solve because the symmetry condition also prevents any flexural vibrations in 
this direction.

This example uses both rectangular and brick meshes. In 2D, first draw the geometry 
and use a mapped mesh to mesh it. In 3D, you utilize work planes by drawing a 2D 
view of the beam into the work plane. Then mesh it using the mapped mesh, and 
finally, a mesh extrusion creates the true 3D geometry.

In the damped eigenfrequency analysis, the resonator’s quality factor Q is available as 
a predefined variable Qfastor. In the 3D analysis, you can use a predefined variable 
Ent for the elastic part of the entropy Selast. Use the explicit expression given in 
Equation 15 for the 2D problem.
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Modeling Using the Graphical User Interface—3D Example

M O D E L  N A V I G A T O R

1 In the Model Navigator select 3D in the Space dimension list.

2 Click Multiphysics.

3 From the list of application modes, select MEMS Module>Structural Mechanics> 
Solid, Stress-Strain>Damped eigenfrequency analysis.

4 Click Add.

5 From the list of application modes select  
COMSOL Multiphysics>Heat Transfer>Conduction>Steady-state analysis.

6 Click Add.

7 Click OK.

O P T I O N S  A N D  S E T T I N G S

Select Options>Constants and enter constants from the following table; when finished, 
click OK.

The constant f0 serves as an initial guess for the eigenfrequency solver.

G E O M E T R Y  M O D E L I N G

1 Select Draw>Work-Plane Settings.

2 On the Quick page select the z-x check box.

3 Click OK. The 2D work plane becomes active.

4 Shift-click the Rectangle/Square button on the Draw toolbar.

NAME EXPRESSION DESCRIPTION

E 157[GPa] Young’s modulus

rho 2330[kg/m^3] Density

nu 0.3 Poisson’s ratio

alpha 2.6e-6[1/K] Thermal expansion coefficient

Cp 700[J/(kg*K)] Specific heat capacity

k 90[W/(m*K)] Thermal conductivity

T0 300[K] Ambient and initial beam 
temperature

f0 4.730^2*sqrt(E/(rho*12))* 
12[um]/(2*pi*(400[um])^2)

Theoretical estimate for the 
natural frequency
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5 In the Width edit field type 12e-6, and in the Height edit field type 400e-6.

6 Click OK, then click the Zoom Extents button on the Main toolbar.

M E S H  G E N E R A T I O N

1 In the work plane select Mesh>Mapped Mesh Parameters.

2 In the Subdomain page select the first subdomain and click the Boundary tab.

3 Select Boundary 1.

4 Select the Constrained edge element distribution check box, then enter 25 in the 
Number of edge elements edit field.

5 Select Boundary 2.

6 Select the Constrained edge element distribution check box, then enter 4 in the 
Number of edge elements edit field.

7 Click Remesh, then click OK.

8 Select Mesh>Extrude Mesh.

9 In the Distance edit field type 10e-6.

10 Change to the Mesh page

11 In the Number of element layers edit field type 2.

12 Click OK.

The 3D geometry should open automatically.

P H Y S I C S  S E T T I N G S

Subdomain Settings
1 From the Multiphysics menu select 1 Geom1: Solid, Stress-Strain (smsld).

2 Select Physics>Subdomain Settings.

3 Select Subdomain 1, and in the Material page enter settings according to the 
following table: 

4 Click the Load tab.

PROPERTY VALUE

 E E

 ν nu

 α alpha

 ρ rho
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5 Select Include thermal expansion and type T for Temp and 0 for Tempref.

6 Change to the Damping page.

7 From the Damping model list select No damping.

8 Click OK.

9 From the Multiphysics menu select 2 Geom1: Heat Transfer by Conduction (ht).

10 Select Physics>Subdomain Settings.

11 See that Subdomain 1 is selected and in the Material page enter settings from the 
following table:

12 Click OK.

Boundary Conditions
1 From the Multiphysics menu, select 1 Geom1: Solid, Stress-Strain (smsld).

2 Select Physics>Boundary Settings.

3 Select Boundaries 1 and 6.

4 On the Constraint page, set Constraint condition to Fixed.

5 Select Boundary 2.

6 Set Constraint condition list to Symmetry plane.

7 Click OK.

8 From the Multiphysics menu, select 2 Geom1: Heat Transfer by Conduction (ht).

9 Select Physics>Boundary Settings.

10 Verify that Thermal insulation is the default value.

11 Click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Choose Solve>Solver Parameters.

2 Go to the General page.

3 Type 1 for Desired number of eigenfrequencies.

4 Type f0 for Search for eigenfrequencies around.

5 Go to the Advanced page.

6 Locate the Scaling of variables area and choose Manual for Type of scaling.

PROPERTY VALUE

 k (isotropic) k

 Q -jomega_smsld*(rho*Cp*T+T0*Ent_smsld)
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7 In the Manual scaling edit field, type u 1e-4 v 1e-4 w 1e-4 T 1. Click OK.

8 Click the Solve button on the Main toolbar.

The solver finds a solution with an eigenfrequency of approximately 63,394 Hz.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate the plot in Figure 2 follow these steps:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General Page verify that the Boundary, Deformed shape, and Geometry edges 
check boxes are selected and that all others are cleared.

3 Go to the Boundary page and select Heat Transfer by Conduction (ht)>Temperature 
from the Predefined quantities list.

4 Click OK.

You can see the eigenfrequency in the postprocessing plot. Use the Global Data Display 
dialog box to calculate the Q value: 

1 Choose Postprocessing>Data Display>Global.

2 In the Expression edit field, type Qfactor_smsld.

3 Click Apply. You find the Q value in the message log.

Modeling Using the Graphical User Interface—2D Example

Start the model in the Model Navigator. 

1 In the Model Navigator select 2D.

2 Click Multiphysics.

3 From the list of application modes select  
MEMS Module>Structural Mechanics>Plane Stress>Damped eigenfrequency analysis.

4 Click Add.

5 From the list of application modes select  
COMSOL Multiphysics>Heat Transfer>Conduction>Steady-state analysis.

6 Click Add, then click OK.
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O P T I O N S  A N D  S E T T I N G S

Choose Options>Constants and enter constants from the following table:

The constant f0 serves as an initial guess for the eigenfrequency solver.

G E O M E T R Y  M O D E L I N G

1 Shift-click the Rectangle/Square button on the Draw toolbar.

2 In the Width edit field type 400e-6, and in the Height edit field type 12e-6.

3 Click OK, then click the Zoom Extents button on the Main toolbar.

M E S H  G E N E R A T I O N

1 In the work plane select Mesh>Mapped Mesh Parameters.

2 On the Subdomain page, select Subdomain 1.

3 Click the Boundary tab. Select Boundary 1.

4 Select the Constrained edge element distribution check box, then type 5 in the 
Number of edge elements edit field.

5 Select Boundary 2.

6 Select the Constrained edge element distribution check box, then type 25 in the 
Number of edge elements edit field.

7 Click Remesh, then click OK.

P H Y S I C S  S E T T I N G S

Subdomain Settings—Plane Stress
1 From the Multiphysics menu, select 1 Plane Stress (smps).

2 Choose Physics>Subdomain Settings.

NAME EXPRESSION DESCRIPTION

E 157[GPa] Young’s modulus

rho 2330[kg/m^3] Density

nu 0.3 Poisson’s ratio

alpha 2.6e-6[1/K] Thermal expansion coefficient

Cp 700[J/(kg*K)] Specific heat capacity

k 90[W/(m*K)] Thermal conductivity

T0 300[K] Ambient and initial beam 
temperature

f0 4.730^2*sqrt(E/(rho*12))* 
12[um]/(2*pi*(400[um])^2)

Theoretical estimate for the 
natural frequency
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3 Select Subdomain 1. On the Material page, enter the following settings:

4 Click the Load tab.

5 Select the Include thermal expansion check box. Enter T for Temp and 0 for Tempref.

6 Change to the Damping page.

7 From the Damping model list, select No damping, then click OK.

Subdomain Settings—Heat Transfer by Conduction
1 From the Multiphysics menu, select 2 Heat Transfer by Conduction (ht).

2 Choose Physics>Subdomain Settings.

3 Verify that Subdomain 1 is selected, then on the Physics page enter settings 
according to the following table; when finished, click OK.

Boundary Conditions—Plane Stress
1 From the Multiphysics menu, select 1 Plane Stress (smps).

2 Choose Physics>Boundary Settings. Select Boundaries 1 and 4.

3 On the Constraint page, set Constraint condition to Fixed, then click OK.

Boundary Conditions—Heat Transfer by Conduction
1 From the Multiphysics menu, select 2 Heat Transfer by Conduction (ht).

2 Choose Physics>Boundary Settings.

3 Verify that Thermal insulation is the default value, then click OK.

C O M P U T I N G  T H E  S O L U T I O N

1 Choose Solve>Solver Parameters.

2 On the General page, enter 1 for Desired number of eigenfrequencies.

PROPERTY VALUE

 E E

 ν nu

 α alpha

 ρ rho

 thickness 20e-6

PROPERTY VALUE

 k (isotropic) k

 Q -jomega_smps*(rho*Cp*T+T0*Ent_smps)
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3 Enter f0 for Search for eigenfrequencies around.

4 Go to the Advanced page.

5 Locate the Scaling of variables area and choose Manual for Type of scaling.

6 In the Manual scaling edit field, type u 1e-4 v 1e-4 T 1. Click OK.

7 Click the Solve button on the Main toolbar.

The solver finds a solution with an eigenfrequency of approximately 63,045 Hz.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

To generate the plot in Figure 3 follow the steps below:

1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, verify that the Boundary, Deformed shape, and Geometry edges 

check boxes are selected, and that all others are cleared.

3 On the Surface page, select Heat Transfer by Conduction (ht)>Temperature from the 
Predefined quantities list. Click OK.

You can see the eigenfrequency in the postprocessing plot. Use the Global Data Display 

dialog box to calculate the Q value: 

1 Select Postprocessing>Data Display>Global.

2 In the Expression edit field type Qfactor_smps.

3 Click Apply. The Q value appears in the message log below the drawing area.
T H E R M O E L A S T I C  D A M P I N G  I N  A  M E M S  R E S O N A T O R  |  16


	Thermoelastic Damping in a MEMS Resonator
	Introduction
	Model Definition
	Results and Discussion
	Modeling in COMSOL Multiphysics
	References
	Modeling Using the Graphical User Interface-3D Example
	Modeling Using the Graphical User Interface-2D Example


