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C y l i n d e r  Ro l l e r  C on t a c t

Introduction

Consider an infinitely long steel cylinder resting on a flat aluminum foundation, where 
both structures are elastic. The cylinder is subjected to a point load along its top. The 
objective of this study is to find the contact pressure distribution and the length of 
contact between the foundation and the cylinder. An analytical solution exists, and this 
model includes a comparison against the COMSOL Multiphysics solution. This model 
is based on a NAFEMS benchmark (see Ref. 1).

Model Definition

This is clearly a plane strain problem and the Plane Strain application mode from the 
Structural Mechanics Module is thus a suitable (two-dimensional) application mode. 
The geometry is reduced to half of the geometry at the vertical symmetry axis due to 
symmetry reasons.

Figure 1: Geometry in model

The cylinder is subjected to a point load along its top with an intensity of 35 kN. Both 
the cylinder and block material are elastic, homogeneous, and isotropic. 
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The contact modeling method in this example does not include friction as described 
in Ref. 1. This model uses a contact pair, which is a straightforward way to implement 
a contact problem using the Structural Mechanics Module.

Results and Discussion

The deformed shape and the Von Mises stress distribution are depicted in Figure 2.

Figure 2: Deformation and von Mises stress at the contact area.

The analytical solution for the contact pressure as a function of the x-coordinate is 
given by

where Fn is the applied load (load/length), E' the combined elasticity modulus, R' the 
combined radius, and x is the x-axis coordinate.
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The combined Young’s modulus and radius are defined as:

In these equations, E1 and E2 are Young’s modulus of the roller and the block, 
respectively, and R1 is the radius of the roller.

This gives a contact length of 6.21 mm and a maximum contact pressure of 3585 MPa.

The contact pressure along the contact area for both the analytical and the COMSOL 
Multiphysics solution are depicted in Figure 3. The COMSOL Multiphysics solution 
is the solid line, the analytical result is the dashed line.

Figure 3: Analytical pressure distribution and COMSOL Multiphysics solution (dashed).

The maximum contact pressure obtained with COMSOL Multiphysics is 3581 MPa, 
which is in good agreement with the analytical solution.

The maximum contact length (equivalent to a null contact pressure) is evaluated at 
6.31 mm.
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Modeling Using COMSOL Multiphysics

The Structural Mechanics Module supports contact boundary conditions using 
contact pairs. The contact pair is defined by a master (contacting) boundary and a slave 
(contacted) boundary. The contact boundary pair comprises a flat boundary and a 
curved boundary. The flat boundary is defined as the master boundary and the curved 
boundary as the slave boundary.

Because contact is only present in a small area, a local mesh refinement is required. Due 
to the geometry shape, you use a free mesh for the cylinder domain and a mapped 
mesh for the aluminum block. The block geometry requires some modification in 
order to set up a refined mesh area.

This example assumes a nominal thickness (thickness = 1).

The selected length unit in this model is mm, so the MPa unit system, which is based 
on mm as the length unit, is a suitable unit system.

Model Library path: Structural_Mechanics_Module/Benchmark_Models/
cylinder_roller_contact

Modeling Using the Graphical User Interface

M O D E L  N A V I G A T O R

1 On the New page, select 2D from the Space dimension list.

2 Expand to the next submenu by clicking on Structural Mechanics Module>

Plane Strain>Static analysis.

3 Click OK.
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O P T I O N S  A N D  S E T T I N G S

1 From the Options menu select Constants and enter the following constant names, 
expressions, and descriptions (optional); when done, click OK.

G E O M E T R Y  M O D E L I N G

1 In the Draw menu select Use Assembly.

1 Shift-click the Ellipse/Circle (Centered) button on the Draw toolbar, then set the 
Radius to 50 and the position of the center to (0, 50). Click OK.

2 Shift-click the Rectangle/Square button on the Draw toolbar and set both Width and 
Height to 200. Set the corner position to (100, 200). Click OK.

3 Click the Zoom Extents button on the Main toolbar.

4 Draw a second rectangle, this one of width 100 and height 300 with the lower left 
corner at (100, 200).

5 Click the Create Composite Object button on the Draw toolbar and type the 
expression (C1+R1)-R2 in the Set formula edit field. Click OK.

6 Choose Specify Objects>Square from the Draw menu to create two squares with the 
following specifications:

NAME EXPRESSION DESCRIPTION

E1 70e3[MPa] Block Young's modulus

E2 210e3[MPa] Cylinder Young's modulus

nu 0.3 Poisson's ratio

Fn 35[kN] External load

E_star 2*E1*E2/((E1+E2)*(1-nu^2)) Combined Young's modulus

R 50[mm] Combined radius

th 1[mm] Thickness

lc 10[mm] Estimated contact length

a sqrt(8*Fn*R/(pi*E_star*th)) Contact length

pmax sqrt(Fn*E_star/(2*pi*R*th)) Maximum contact pressure

PROPERTY SQUARE 1 SQUARE 2

Width 100 25

Base Corner Corner

x 0 0

y -100 -25
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7 Choose Specify Objects>Line from the Draw menu and create a line between grid 
point (25, 25) and grid point (100, 100).

The mesh needs to be refined in the contact area. To do this in an efficient way, 
divide the curved boundary into two separate boundaries. To achieve this, add a 
point along the curved boundary.

8 Draw a Point at the origin (0, 0).

9 Click the Rotate button on the Draw toolbar, then set the Rotation angle to 10 
degrees and the y-coordinate of the Center point to 50. Click OK.

10 Select all domains (press Ctrl+A), then click the Split Object button on the Draw 
toolbar.

11 Select all the geometry objects of the top part (CO3 and PT2), then click the Coerce 

to Solid button on the Draw toolbar.

12 Select all the geometry objects of the bottom part (CO2, CO4, CO5, and B2), then 
click the Coerce to Solid button.

P H Y S I C S  S E T T I N G S

Model Settings
1 In the Physics menu, go to Model Settings and select MPa from the Base unit system 

list.
C Y L I N D E R  R O L L E R  C O N T A C T  |  6



cylinder_roller_contact.book  Page 7  Thursday, June 4, 2009  3:31 PM
2 Click OK.

Subdomain Settings
1 Choose Physics>Subdomain Settings to specify the subdomain settings for the Plane 

Strain application mode according to the following table:

The nominal thickness is used; make sure that thickness is set to 1 for all subdomains.

2 Click OK.

Boundary Conditions
1 Choose Physics>Boundary Settings to open the Boundary Settings dialog box; then 

specify the following constraint conditions:

The other boundaries are free, which is the default boundary condition.

2 Click OK.

Point Settings
The external load is a point load. Due to the symmetry, apply one half of the total force 
on the studied geometry:

1 From the Physics menu select Point Settings.

2 In the Point Settings dialog box select Point 11.

3 Click the Load tab, and then type -Fn/2 in the Fy edit field.

4 Click OK.

Contact Pairs
Define a contact pair for Boundaries 7 and 14. A general advice is to set the curved 
surface as slave (contacting) boundary and the straight surface as master (contacted) 
boundary. The top boundary (number 7) is set to slave boundary and the bottom 
boundary (number 14) as master boundary in this model. The steel block is also the 
correct master surface because it has a high stiffness.

1 From the Physics menu select Contact Pairs.

2 In the Contact Pairs dialog box, click New.

SETTINGS SUBDOMAINS 1–4 SUBDOMAIN 5

E E1 E2

  nu nu

SETTINGS BOUNDARIES 1, 3, 5, 13 BOUNDARY 2

Constraint condition Symmetry plane Fixed
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3 In the Master boundaries list, select Boundary 7.

4 Click the Check Selected button below the Master boundaries list.

5 In the Slave boundaries list select Boundary 14.

6 Click the Check Selected button below the Slave boundaries list.

7 Click OK.

The next step is to specify the contact parameters in the Boundary Settings dialog 
box.

8 In the Boundary Settings dialog box, click the Pairs tab, and select Pair 1 (contact).

Note: To reduce the number of iteration steps and improve convergence, it is good 
practice to set an initial contact pressure as close to the solution as possible. A good 
approximation is to use the value of the external pressure, in this case the external 
point load divided by an estimated contact length and the thickness. In this model 
you need to set an initial contact pressure to make the model stable for the initial 
conditions.

9 On the Contact, Initial page, type (Fn/2)/(lc*th) in the Contact pressure edit field 
(the division by 2 is to account for the symmetry).

10 Click OK.

M E S H  G E N E R A T I O N

You can achieve an accurate contact pressure by refining the mesh around the contact 
zone. A general recommendation is to have at least 10 contacting nodes along the slave 
contact boundary. Apply an element size of 0.59 mm for the cylinder and 1.5 mm for 
the block. Due to the geometry shape, use a free mesh (triangular elements) for the 
cylinder and a mapped mesh (quadrilateral elements) for the block.

1 Open the Free Mesh Parameters dialog box by selecting Free Mesh Parameters from 
the Mesh menu.

2 Click the Boundary tab. Select Boundary 14, then type 0.59 in the Maximum element 

size edit field.

3 Click the Subdomain tab, then select Subdomain 5. Click OK.

4 Click the Mesh Selected (Free) button on the Mesh toolbar.

In the message log you can see that the free mesh is composed of around 360 
elements.
C Y L I N D E R  R O L L E R  C O N T A C T  |  8



cylinder_roller_contact.book  Page 9  Thursday, June 4, 2009  3:31 PM
5 Open the Mapped Mesh Parameters dialog box by selecting Mapped Mesh Parameters 

from the Mesh menu.

6 On the Boundary page, select Boundaries 3, 5, and 7. Then select Constrained edge 

element distribution and type 20 in the Number of edge elements edit field.

7 On the Boundary page, select Boundary 1. Then select the Constrained edge element 

distribution and type 10 in the Number of edge elements edit field. Click Apply.

8 Go to Subdomain page and select Subdomains 1, 2, 3, and 4.

9 Click the Mesh Selected button. Click OK.

The information in the message log shows that the total mesh consists of 
approximately 1750 elements (roughly 360 elements for the free mesh and 1400 
elements for the mapped mesh).

C O M P U T I N G  T H E  S O L U T I O N

Click the Solve button on the Main toolbar.

PO S T P R O C E S S I N G  A N D  V I S U A L I Z A T I O N

The default plot shows the von Mises stress. Because of the point-load constraint, a 
stress concentration develops on the top of the cylinder. Due to the automatic 
plot-range settings, the stress around the contact surface looks almost identical.
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1 Click the Plot Parameters button on the Main toolbar.

2 On the General page, select the Surface and Boundary check boxes and clear the 
Geometry edges check box in the Plot type area.

3 On the Surface page, click the Range button. In the Color Range dialog box clear the 
Auto check box, then type 2500 in the Max edit field. Click OK.

4 On the Boundary page, type 1 in the Expression edit field on the Boundary Data tab. 
Click the Uniform color option button in the Boundary color area, then click the Color 

button and select black. Click OK.

5 Click OK.

Zoom in on the contact area to get the following plot:

The instructions below show how to create a line plot to compare the analytical contact 
pressure distribution with the contact pressure calculated by the model.

1 Choose Options>Expressions>Boundary Expressions and select Boundary 14. Enter 
the following constant names and expressions:

NAME EXPRESSION

theta atan2(y-50,x)+pi/2
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2 Click OK.

3 In the Solve menu, select Update Model.

You can now plot the analytical expression of the contact pressure.

4 Choose Postprocessing>Domain Plot Parameters.

5 Click the Line/Extrusion tab, then from the Predefined quantities list select Contact 

pressure, contact Pair 1.

6 Select Boundary 14 (the slave boundary), then click Apply to generate a plot of the 
contact pressure calculated in the model.

7 In the Expression edit field type p_analytical.

8 Click the Line Settings button, then select Color in the Line color list, and Dashed line 
in the Line style list. Click OK.

9 Click the General tab, then select Keep current plot.

10 Click the Title/Axis button and type Contact pressure vs. arc length (blue: 
calculated, red: analytical) in the Title edit field. In the First axis label edit 
field type mm and in the Second axis label edit field type MPa. Click OK.

x_local sqrt(x^2+(y-50)^2)*theta

p_analytical pmax*sqrt(1-(x_local/a)^2)

NAME EXPRESSION
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11 Click OK in Domain Plot Parameters dialog box to generate the plot of the analytical 
expression for the contact pressure.
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